import Foundation
let pattern = #"(<a.*?href="//.*?">.*?</a>)|(<a href="http://site.ru" class="link_external"><span class="link_text">Заголовок</span></a>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
dqwqwfqfewf fwefwef fwe fw fwefwefwe
fwefwefwefwefwefwefwefwef fwef.
<a href="/dwdw.php/">dwdqwdqwd</a>
fwefwefwefwefewfwefwefwefwfwefwefwefwefwefew.
<a href="http://site.ru" class="link_external"><span class="link_text">Заголовок</span></a>
dqwqwfqfewf fwefwef fwe fw fwefwefwe
<a href="//dwdw.php">dwdqwdqwd</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)