re = /(<a.*?href="\/\/.*?">.*?<\/a>)|(<a href="http:\/\/site.ru" class="link_external"><span class="link_text">Заголовок<\/span><\/a>)/
str = 'dqwqwfqfewf fwefwef fwe fw fwefwefwe
fwefwefwefwefwefwefwefwef fwef.
<a href="/dwdw.php/">dwdqwdqwd</a>
fwefwefwefwefewfwefwefwefwfwefwefwefwefwefew.
<a href="http://site.ru" class="link_external"><span class="link_text">Заголовок</span></a>
dqwqwfqfewf fwefwef fwe fw fwefwefwe
<a href="//dwdw.php">dwdqwdqwd</a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end