// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<a.*?href="//.*?">.*?</a>)|(<a href="http://site.ru" class="link_external"><span class="link_text">Заголовок</span></a>)"#).unwrap();
let string = "dqwqwfqfewf fwefwef fwe fw fwefwefwe
fwefwefwefwefwefwefwefwef fwef.
<a href=\"/dwdw.php/\">dwdqwdqwd</a>
fwefwefwefwefewfwefwefwefwfwefwefwefwefwefew.
<a href=\"http://site.ru\" class=\"link_external\"><span class=\"link_text\">Заголовок</span></a>
dqwqwfqfewf fwefwef fwe fw fwefwefwe
<a href=\"//dwdw.php\">dwdqwdqwd</a>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}