import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img src.+?>";
final String string = "<p><img src=\"/upload/img/te.jpg\" height=\"240\" /></p>\n"
+ " \n"
+ "<p>специально предназначенный для использования <img title=\"тут\" alt=\"есть\" src=\"/upload/img/te.jpg\" height=\"240\" /> в навесных и кар </p>\n"
+ " \n"
+ "<img src=\"/upload/img/te.jpg\" height=\"240\" />\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}