re = /<img src.+?>/i
str = '<p><img src="/upload/img/te.jpg" height="240" /></p>
<p>специально предназначенный для использования <img title="тут" alt="есть" src="/upload/img/te.jpg" height="240" /> в навесных и кар </p>
<img src="/upload/img/te.jpg" height="240" />
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end