const regex = new RegExp('<img src.+?>', 'guis')
const str = `<p><img src="/upload/img/te.jpg" height="240" /></p>
<p>специально предназначенный для использования <img title="тут" alt="есть" src="/upload/img/te.jpg" height="240" /> в навесных и кар </p>
<img src="/upload/img/te.jpg" height="240" />
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}