$re = '~<img src.+?>~uis';
$str = '<p><img src="/upload/img/te.jpg" height="240" /></p>
<p>специально предназначенный для использования <img title="тут" alt="есть" src="/upload/img/te.jpg" height="240" /> в навесных и кар </p>
<img src="/upload/img/te.jpg" height="240" />
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);