#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?isx)\[hide=([^\]]*)\]" & @CRLF & _
"(" & @CRLF & _
" (?: [^\[]+ | (?! \[/?hide ) . | (?R) )++" & @CRLF & _
")" & @CRLF & _
"\[/hide\]"
Local $sString = "[hide=0] " & @CRLF & _
"" & @CRLF & _
"[hide=]" & @CRLF & _
"" & @CRLF & _
" test [hide=] [/hide] [hide=1] [/hide] " & @CRLF & _
"" & @CRLF & _
"[/hide]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")