$re = '@\[hide=([^\]]*)\]
(
(?: [^\[]+ | (?! \[/?hide ) . | (?R) )++
)
\[/hide\]@isx';
$str = '[hide=0]
[hide=]
test [hide=] [/hide] [hide=1] [/hide]
[/hide]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);