import Foundation
let pattern = #"""
\[hide=([^\]]*)\]
(
(?: [^\[]+ | (?! \[/?hide ) . | (?R) )++
)
\[/hide\]
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = #"""
[hide=0]
[hide=]
test [hide=] [/hide] [hide=1] [/hide]
[/hide]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}