re = /\[hide=([^\]]*)\]
(
(?: [^\[]+ | (?! \[\/?hide ) . | (?R) )++
)
\[\/hide\]/ix
str = '[hide=0]
[hide=]
test [hide=] [/hide] [hide=1] [/hide]
[/hide]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end