using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z]|(?!\A)\G)(\d+z)";
string input = @"A42z19z037z21zB942z21z4842zC33z449z3884z68z20z";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}