re = /([A-Z]|(?!\A)\G)(\d+z)/
str = 'A42z19z037z21zB942z21z4842zC33z449z3884z68z20z'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end