const regex = /([A-Z]|(?!\A)\G)(\d+z)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z]|(?!\\A)\\G)(\\d+z)', 'g')
const str = `A42z19z037z21zB942z21z4842zC33z449z3884z68z20z`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}