using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\S+\s+){0,2}\p{P}?myself\p{P}?(?:\s+\S+){0,2}";
string input = @"Me, my dog and “myself“ are going on a vacation. Irene and myself are broke. Myself is here :P John and myself!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}