// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\S+\s+){0,2}\p{P}?myself\p{P}?(?:\s+\S+){0,2}").unwrap();
let string = "Me, my dog and “myself“ are going on a vacation. Irene and myself are broke. Myself is here :P John and myself!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}