$re = '/(?:\S+\s+){0,2}\p{P}?myself\p{P}?(?:\s+\S+){0,2}/m';
$str = 'Me, my dog and “myself“ are going on a vacation. Irene and myself are broke. Myself is here :P John and myself!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);