package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\S+\s+){0,2}\p{P}?myself\p{P}?(?:\s+\S+){0,2}`)
var str = `Me, my dog and “myself“ are going on a vacation. Irene and myself are broke. Myself is here :P John and myself!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}