using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[.*?\]";
string input = @"[caption id=""attachment_90"" align=""alignleft"" width=""400""] xxxxxxxxxxxxxxxxxxxx[/caption]";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}