re = /\[.*?\]/mi
str = '[caption id="attachment_90" align="alignleft" width="400"] xxxxxxxxxxxxxxxxxxxx[/caption]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end