$re = '/\[.*?\]/mi';
$str = '[caption id="attachment_90" align="alignleft" width="400"] xxxxxxxxxxxxxxxxxxxx[/caption]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);