using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|;)cheese:(?P<value>[^;]+)";
string input = @"no-cheese:no;sauce:yes;chicken:brown;cheese:yes";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}