$re = '/(^|;)cheese:(?P<value>[^;]+)/';
$str = 'no-cheese:no;sauce:yes;chicken:brown;cheese:yes';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);