re = /(^|;)cheese:(?P<value>[^;]+)/
str = 'no-cheese:no;sauce:yes;chicken:brown;cheese:yes'
# Print the match result
str.match(re) do |match|
puts match.to_s
end