package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|;)cheese:(?P<value>[^;]+)`)
var str = `no-cheese:no;sauce:yes;chicken:brown;cheese:yes`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}