package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<protocol>s?ftp):\/\/(?<user>[^@\s]+)@(?<host>[^\?\s:]+)(?::(?<port>[0-9]+))?(?:\?(?<password>.+))?`)
var str = `sftp://username@upload.google.com:22?c0n|\|3ctEc1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}