use strict;
my $str = 'sftp://username@upload.google.com:22?c0n|\\|3ctEc1';
my $regex = qr/(?<protocol>s?ftp):\/\/(?<user>[^@\s]+)@(?<host>[^\?\s:]+)(?::(?<port>[0-9]+))?(?:\?(?<password>.+))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}