re = /(?<protocol>s?ftp):\/\/(?<user>[^@\s]+)@(?<host>[^\?\s:]+)(?::(?<port>[0-9]+))?(?:\?(?<password>.+))?/m
str = 'sftp://username@upload.google.com:22?c0n|\\|3ctEc1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end