const regex = /(?<protocol>s?ftp):\/\/(?<user>[^@\s]+)@(?<host>[^\?\s:]+)(?::(?<port>[0-9]+))?(?:\?(?<password>.+))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<protocol>s?ftp):\\\/\\\/(?<user>[^@\\s]+)@(?<host>[^\\?\\s:]+)(?::(?<port>[0-9]+))?(?:\\?(?<password>.+))?', 'gm')
const str = `sftp://username@upload.google.com:22?c0n|\\|3ctEc1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}