# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?P<prefix>.*?)(?P<number>[0-9]+)$//gm;t' <<< "ABC123
123
A9B9C123"