import re
regex = re.compile(r"^(?P<prefix>.*?)(?P<number>[0-9]+)$", flags=re.MULTILINE)
test_str = ("ABC123\n"
"123\n"
"A9B9C123")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)