$re = '~^(?P<prefix>.*?)(?P<number>[0-9]+)$~m';
$str = 'ABC123
123
A9B9C123';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;