use strict;
my $str = 'ABC123
123
A9B9C123';
my $regex = qr~^(?P<prefix>.*?)(?P<number>[0-9]+)$~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";