using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href=""ftp:([^""]+)"">";
string input = @"<a href=""ftp://mysite.com""> some stuff </a>
<a href=""ftp://mysite.com"" class=""foo""> some stuff </a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}