re = /<a href="ftp:([^"]+)">/
str = '<a href="ftp://mysite.com"> some stuff </a>
<a href="ftp://mysite.com" class="foo"> some stuff </a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end