#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Link to Monitoring.*<\/a>.*<\/th><td style='padding:10px;border:1px solid;vertical-align:top;text-align:left'>([\\s\\S])<\/td>"
Local $sString = "Link to Monitoring</a>\n </th><td style='padding:10px;border:1px solid;vertical-align:top;text-align:left'><a rel='nofollow' href='https://my.pingdom.com/reports/uptime#check=1615711'>https://my.pingdom.com/reports/uptime#check=1615711</a><br/><a rel='nofollow' href='https://my.pingdom.com/reports/uptime#check=1617633'>https://my.pingdom.com/reports/uptime#check=1617633</a><a target='_blank' href=''> </a></td>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")