$re = '/Link to Monitoring.*<\/a>.*<\/th><td style=\'padding:10px;border:1px solid;vertical-align:top;text-align:left\'>([\\\\s\\\\S])<\/td>/m';
$str = 'Link to Monitoring</a>\\n </th><td style=\'padding:10px;border:1px solid;vertical-align:top;text-align:left\'><a rel=\'nofollow\' href=\'https://my.pingdom.com/reports/uptime#check=1615711\'>https://my.pingdom.com/reports/uptime#check=1615711</a><br/><a rel=\'nofollow\' href=\'https://my.pingdom.com/reports/uptime#check=1617633\'>https://my.pingdom.com/reports/uptime#check=1617633</a><a target=\'_blank\' href=\'\'> </a></td>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);