// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Link to Monitoring.*<\/a>.*<\/th><td style='padding:10px;border:1px solid;vertical-align:top;text-align:left'>([\\s\\S])<\/td>").unwrap();
let string = "Link to Monitoring</a>\\n </th><td style='padding:10px;border:1px solid;vertical-align:top;text-align:left'><a rel='nofollow' href='https://my.pingdom.com/reports/uptime#check=1615711'>https://my.pingdom.com/reports/uptime#check=1615711</a><br/><a rel='nofollow' href='https://my.pingdom.com/reports/uptime#check=1617633'>https://my.pingdom.com/reports/uptime#check=1617633</a><a target='_blank' href=''> </a></td>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}