const regex = /Link to Monitoring.*<\/a>.*<\/th><td style='padding:10px;border:1px solid;vertical-align:top;text-align:left'>([\\s\\S])<\/td>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Link to Monitoring.*<\\\/a>.*<\\\/th><td style=\'padding:10px;border:1px solid;vertical-align:top;text-align:left\'>([\\\\s\\\\S])<\\\/td>', 'gm')
const str = `Link to Monitoring</a>\\n </th><td style='padding:10px;border:1px solid;vertical-align:top;text-align:left'><a rel='nofollow' href='https://my.pingdom.com/reports/uptime#check=1615711'>https://my.pingdom.com/reports/uptime#check=1615711</a><br/><a rel='nofollow' href='https://my.pingdom.com/reports/uptime#check=1617633'>https://my.pingdom.com/reports/uptime#check=1617633</a><a target='_blank' href=''> </a></td>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}