#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^\d{1,14}$ | " & @CRLF & _
"^\d{3}-\d{1,3}$ | " & @CRLF & _
"^\d{3}-\d{1,3}-\d{1,4}$ |" & @CRLF & _
"^\d{3}-\d{1,3}-\d{1,4}\s\d{1,4}$"
Local $sString = "333" & @CRLF & _
"333-3" & @CRLF & _
"333-333-3333" & @CRLF & _
"333-333-3333 3333" & @CRLF & _
"33333333333333"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")