package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,14}$ |
^\d{3}-\d{1,3}$ |
^\d{3}-\d{1,3}-\d{1,4}$ |
^\d{3}-\d{1,3}-\d{1,4}\s\d{1,4}$`)
var str = `333
333-3
333-333-3333
333-333-3333 3333
33333333333333`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}