using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{1,14}$ |
^\d{3}-\d{1,3}$ |
^\d{3}-\d{1,3}-\d{1,4}$ |
^\d{3}-\d{1,3}-\d{1,4}\s\d{1,4}$";
string input = @"333
333-3
333-333-3333
333-333-3333 3333
33333333333333";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}