using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ad<\/div>.*?<div>(.*?)<\/div>";
string input = @""""" <div>ad</div> \n\n <div> correct value </div> <div> wrong value </div> """"";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}