const regex = /ad<\/div>.*?<div>(.*?)<\/div>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ad<\\\/div>.*?<div>(.*?)<\\\/div>', '')
const str = `""" <div>ad</div> \\n\\n <div> correct value </div> <div> wrong value </div> """`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}