$re = '/ad<\/div>.*?<div>(.*?)<\/div>/';
$str = '""" <div>ad</div> \\n\\n <div> correct value </div> <div> wrong value </div> """';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);