re = /ad<\/div>.*?<div>(.*?)<\/div>/
str = '""" <div>ad</div> \\n\\n <div> correct value </div> <div> wrong value </div> """'
# Print the match result
str.match(re) do |match|
puts match.to_s
end