import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ad</div>((?!<div>).)*<div>(((?!<\\/div>).)*)</div>";
final String string = "\"\"\" <div>ad</div> \\n\\n <div> correct \n"
+ "value </div> <div> wrong value </div> \"\"\"";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}