re = /ad<\/div>((?!<div>).)*<div>(((?!<\/div>).)*)<\/div>/
str = '""" <div>ad</div> \\n\\n <div> correct
value </div> <div> wrong value </div> """'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end