const regex = new RegExp('ad</div>((?!<div>).)*<div>(((?!<\\/div>).)*)</div>', 'gs')
const str = `""" <div>ad</div> \\n\\n <div> correct
value </div> <div> wrong value </div> """`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}