import re
regex = re.compile(r"(I like to find )(.*?)( in )([^.]*)(\.)(.*)", flags=re.DOTALL)
test_str = ("I like to find something vicous in somewhere bla bla bla.\n"
"https://address.suffix.com/level/somelongurlstuff")
subst = "$4 $2"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)